lkml.org 
[lkml]   [2008]   [Nov]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 1/7] mm: introduce simple_malloc()/simple_free()
Lai Jiangshan wrote:
> Arjan van de Ven wrote:
>> On Mon, 17 Nov 2008 07:39:55 +1000
>>
>> I would go further than this.
>>
>> Make the code just use vmalloc(). Period.
>>
>> But then make vmalloc() smart and try do a direct mapping allocation
>> first, before falling back to a virtual mapping. (and based on size it
>> wouldn't even try it for just big things)
>>
>>
>>
>
> Hi, Arjan van de Ven
>
> (I'll rename simple_malloc/simple_free to kvmalloc/kvfree)
>

I would prefer to find a way to say that one cannot select gfp_mask with this API.

--
Balbir


\
 
 \ /
  Last update: 2008-11-17 05:59    [W:0.057 / U:33.140 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site