[lkml]   [2008]   [Nov]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: sata-nv and 790i
On Sun, 16 Nov 2008 15:11:20 +0900, Tejun Heo <> wrote:

> J.A. Magallón wrote:
> > Hi all...
> >
> > I recently put my hands on a system with an ASUS P5N64 WS Pro mobo:
> >
> >
> >
> > It has a nForce 790i Ultra SLI chipset, the part for the SATA controller
> > is MCP55.
> >
> > The problem is that linux seems to fail to read the hard drive on boot.
> > I will explain.
> >
> > I have tried to install both CentOS 5.2 and Mandriva 2009.0.
> > For CentOS (has a 2.6.18 kernel), the install seems ok, but when I reboot
> > into the just intalled system the kernel hangs just after printing
> > the name of the initrd. Mandriva (2.6.27-rc8) just hungs half the install process.
> > Live versions of both hang on boot saying they can not find the root
> > device.
> >
> > I have found some messages in the net about the MCP55 in that board not
> > being completeley suppported as AHCI in sata_nv, and that some other
> > boards work puttin the SATA controller in 'compatible' mode (with
> > loss of performance).
> > But I can't find any setting in the P5N64 to put SATA in Compat mode.
> >
> > Can I do this via some kernel parameters ?
> > Somabody has this board working ? Do current kernels have better support
> > for this chipset ?
> All three flavors of sata_nv's - generic (yours), nf2/3 and ck804 - had
> various detection problems from 2.6.27-rc1. The problem was that their
> hardresets all worked differently. 2.6.27-rc1 started to favor
> hardresets over softresets and exposed this problem. While trying to
> fix the problem, because all three flavors unexpectedly showed different
> hardreset behaviors, there were some mistakes. A proper fix is included
> in upstream and is queued for -stable. Sorry about the mess.

Thanks for the info. Just a couple more questions (I have to say to our
sysdamins if it can be done or not... :) ).

The point on hardresets clarifies the Mandriva case, where I have an 27-rc8
kernel. But what about the CentOS case ? If problems begun with rc1,
what happens with plain 2.6.18 ? It just doesn't have support for that
controller ? But installer works...

Is this the patch in question:;a=commitdiff;h=814eb57e1799337d9fbb68f5d838afa507dc014e;hp=7bee179aa2a63087ff80bdd7dcb8bd6da209f359

So I suppose that includes this fix.
Can I guess if a kernel would work looking for this code in the source ?

With this info, I can presume that current Mandriva Cooker would work
(it has a .5 kernel), and could check if CentOS people have backported
it in its updates...or do it myself (some CentOS people listening ...? ).
I probably need to install CentOS, its the 'officially supported' distro in
our department.


J.A. Magallon <jamagallon()ono!com> \ Software is like sex:
\ It's better when it's free
Mandriva Linux release 2009.1 (Cooker) for x86_64
Linux (gcc 4.3.2 (GCC) #1 Sun Nov
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2008-11-17 00:09    [W:0.040 / U:33.236 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site