[lkml]   [2008]   [Oct]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: e1000e fails after several S3 resumes (2.6.26 Debian, TP T60)
> hm, does your kernel have CONFIG_PM defined?  

It does have that defined:

$ grep CONFIG_PM /boot/config-2.6.26-1-686
# CONFIG_PM_DEBUG is not set

> if it happens again please include lspci -vvv before and after ethtool
> -r (see below)

I will. Now I'm running BIOS 2.23, so I'm curious whether that
'upgrade' fixes the problem.

I say 'upgrade' because now S3 sleep and wakeup often take 60 seconds.
I've also noticed ACPI errors in the 'dmesg'. Once I have something
reproducible I'll file a bugzilla report.

> device was also claiming successfully transmitting, so I don't know
> why the DHCP packets don't work, can you tcpdump on the network or the
> dhcp server by chance?

I'll do that too on the next failure. Is 'tcpdump host'
sufficient or do I need a few -v switches?

> can you ifconfig eth0 promisc before doing suspend? I'd be curious if
> that fixed it.

If/when it reproduces, I'll add that line to the pre-suspend code. (I
use 's2ram', which I think sleeps with 'echo mem > /sys/power/state' and
does a vt switch on wakeup).

Generally: For making debugging go smoothly, is it worth running a
vanilla kernel rather than the Debian one? I could try or Is running 2.6.27.y not as useful as running 2.6.26.y, in
case the bug is merely hidden but not solved in the new kernel? On the
other hand, I'm tempted to try 2.6.27.y in case it fixes the slow


`Until lions have their historians, tales of the hunt shall always
glorify the hunters.' --African Proverb

 \ /
  Last update: 2008-10-24 16:29    [W:0.061 / U:1.988 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site