lkml.org 
[lkml]   [2008]   [Oct]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Strange ACPI errors sometimes after resume from s2disk
Rafael J. Wysocki wrote:
> [Adding CCs]
>
> On Wednesday, 22 of October 2008, Dmitry Nezhevenko wrote:
>> Hiall. Just got these strange messages with 2.6.27.2. They flood dmesg.. (same block every second).
>>
>> [42016.520062] ACPI: EC: acpi_ec_wait timeout, status = 0x1a, event = "b1=0"
>> [42016.520079] ACPI: EC: input buffer is not empty, aborting transaction
>> [42017.025050] ACPI: EC: acpi_ec_wait timeout, status = 0x1a, event = "b1=0"
>> [42017.025197] ACPI: EC: input buffer is not empty, aborting transaction
>> [42017.025254] ACPI Exception (evregion-0419): AE_TIME, Returned by Handler for [EmbeddedControl] [20080609]
>> [42017.025350] ACPI Error (psparse-0530): Method parse/execution failed [\_SB_.PCI0.SBRG.EC__.BAT1.UPBS] (Node f78353b0), AE_TIME
>> [42017.025546] ACPI Error (psparse-0530): Method parse/execution failed [\_SB_.PCI0.SBRG.EC__.BAT1._BST] (Node f7835400), AE_TIME
>> [42017.025715] ACPI Exception (battery-0360): AE_TIME, Evaluating _BST [20080609]
>>
>> Battery state "freezes" after this.. So if it was charged to 90%, it will
>> be 90% forever. Also information about charger (plugged/unplugged) is not
>> updating... BIOS automatically increases display brightness just after
>> plugging charger but powersave thinks that it's unplugged.
>>
>> After turning laptop off I can't turn it on any more.. I can hear fan noise,
>> but it don't boots (There are no even BIOS splash/message)
>>
>> I should remove battery and wait ~5 seconds...
>>
>> v2.6.26 was non-working here, but as far as I remember, there was no such
>> problem with 2.6.25. It's very difficult to reproduce it (this is just
>> second case for ~2-3 weeks). So bisecting is impossible.
>>
>> Any ideas? Should I fill a bugreport?
Please try changing msleep(1) to udelay(50) in drivers/acpi/ec.c
Do you have msi-laptop module loaded?
Please fill a bugreport and attach all the information there.

Thanks,
Alex.


\
 
 \ /
  Last update: 2008-10-22 09:33    [W:0.045 / U:3.020 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site