[lkml]   [2008]   [Oct]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC] SLUB - define OO_ macro instead of hardcoded numbers
[Christoph Lameter - Wed, Oct 22, 2008 at 09:28:14AM -0700]
> On Wed, 22 Oct 2008, Cyrill Gorcunov wrote:
>> Please check -- wouldn't it be better to use such a macro?
> Looks good. But could you rename OO_MAX to something different? There is
> already s->max which may cause confusion because s->max is the maximum
> number of objects in a slab. OO_MAX is the maximum mask?

I supposed it would mean maximum object number inside page (ie quantity) which
is happen to be the same value as OO_MASK. Maybe OO_MAX_OBJ?

- Cyrill -

 \ /
  Last update: 2008-10-22 18:39    [W:0.041 / U:3.868 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site