[lkml]   [2008]   [Oct]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 1/2] ftrace: make dynamic ftrace more robust

On Wed, 22 Oct 2008, Steven Rostedt wrote:
> >
> > > + /* kprobes was not the fault */
> > > + ftrace_kill_atomic();
> >
> > while at it, ftrace_kill_atomic() is a misnomer.
> >
> > Please use something more understandable and less ambigious, like
> > "ftrace_turn_off()". Both 'kill' and 'atomic' are heavily laden phrases
> > used for many other things in the kernel.

I agree with your "atomic" part but the 'kill' I do not. Yes, it is
unfortunate that Unix used 'kill' to send signals. But the Unix name is
the misnomer. The problem with a "ftrace_turn_off" or anything similar,
is that people will likely use it to temporarily disable ftrace when they
need to do some sensitive code that they can not allow tracing on.
Then they will be confused when they can not find a "ftrace_turn_on()".

We already use "disable" to shut down ftrace and put it back into the
"NOP" state. We have "stop" and "start" to stop function tracing quickly
(just a bit is set, no conversion of code).

I figured "kill" is self explanatory. You use it when you want to kill
ftrace and do not want it to come back. We have no "ftrace_resurrect"
(well, not yet ;-)

I think most developers know the "kill" meaning. If you do not like the
name, you can change it.

-- Steve

 \ /
  Last update: 2008-10-22 13:31    [W:0.046 / U:2.120 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site