lkml.org 
[lkml]   [2008]   [Jan]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    SubjectRe: kexec refuses to boot latest -mm
    Date
    On Thursday, 3 of January 2008, Dhaval Giani wrote:
    > On Mon, Dec 31, 2007 at 10:08:43AM -0500, Vivek Goyal wrote:
    > > On Sat, Dec 29, 2007 at 11:11:13AM +0530, Dhaval Giani wrote:
    > > > On Fri, Dec 28, 2007 at 09:27:39AM -0500, Vivek Goyal wrote:
    > > > > On Fri, Dec 28, 2007 at 06:15:32PM +0530, Dhaval Giani wrote:
    > > > > > Hi Vivek,
    > > > > >
    > > > > > I can't seem to get the latest -mm (2.6.24-rc6-mm1) to boot with
    > > > > > kexec. It just gets stuck at "Starting new kernel".
    > > > > >
    > > > > > It does boot normally when booted as the first kernel.
    > > > > >
    > > > > > Any hints debugging? (x86 architecture)
    > > > >
    > > > > I generally try few things.
    > > > >
    > > > > - Specify earlyprintk= parameter for second kernel and see if control
    > > > > is reaching to second kernel.
    > > > >
    > > > > - Otherwise specify --console-serial parameter on "kexec -l" commandline
    > > > > and it should display a message "I am in purgatory" on serial console.
    > > > > This will just mean that control has reached at least till purgatory.
    > > > >
    > > >
    > > > Ok, so it reaches till here. I get "I'm in purgatory" on the console.
    > >
    > > One more thing. Is 2.6.24-rc6 working properly?
    > >
    >
    > 2.6.24-rc5 boots, so does 2.6.24-rc5-mm1. 2.6.24-rc6 does not boot, nor
    > does 2.6.24-rc6-mm1. Its a regression.

    Added to the list of reported regressions as:
    http://bugzilla.kernel.org/show_bug.cgi?id=9682

    Thanks,
    Rafael


    \
     
     \ /
      Last update: 2008-01-03 22:43    [W:0.021 / U:31.068 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site