lkml.org 
[lkml]   [2008]   [Jan]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH 3/7] X86: Fix trailing statements should be on next line
    Hi Paolo,

    On Tue, Jan 29, 2008 at 12:07:44AM +0100, Paolo Ciarrocchi wrote:
    > Fix trailing statements should be on next line

    > -if ( partial_status & SW_C3 ) printk("SW: condition bit 3\n");
    > -if ( partial_status & SW_C2 ) printk("SW: condition bit 2\n");
    > -if ( partial_status & SW_C1 ) printk("SW: condition bit 1\n");
    > -if ( partial_status & SW_C0 ) printk("SW: condition bit 0\n");
    > -if ( partial_status & SW_Summary ) printk("SW: exception summary\n");
    > -if ( partial_status & SW_Stack_Fault ) printk("SW: stack fault\n");
    > -if ( partial_status & SW_Precision ) printk("SW: loss of precision\n");
    > -if ( partial_status & SW_Underflow ) printk("SW: underflow\n");
    > -if ( partial_status & SW_Overflow ) printk("SW: overflow\n");
    > -if ( partial_status & SW_Zero_Div ) printk("SW: divide by zero\n");
    > -if ( partial_status & SW_Denorm_Op ) printk("SW: denormalized operand\n");
    > -if ( partial_status & SW_Invalid ) printk("SW: invalid operation\n");

    > +if ( partial_status & SW_Backward )
    > +printk("SW: backward compatibility\n");
    > +if ( partial_status & SW_C3 )
    > +printk("SW: condition bit 3\n");
    > +if ( partial_status & SW_C2 )
    > +printk("SW: condition bit 2\n");
    > +if ( partial_status & SW_C1 )
    > +printk("SW: condition bit 1\n");
    > +if ( partial_status & SW_C0 )
    > +printk("SW: condition bit 0\n");
    > +if ( partial_status & SW_Summary )
    > +printk("SW: exception summary\n");
    > +if ( partial_status & SW_Stack_Fault )
    > +printk("SW: stack fault\n");
    > +if ( partial_status & SW_Precision )
    > +printk("SW: loss of precision\n");
    > +if ( partial_status & SW_Underflow )
    > +printk("SW: underflow\n");
    > +if ( partial_status & SW_Overflow )
    > +printk("SW: overflow\n");
    > +if ( partial_status & SW_Zero_Div )
    > +printk("SW: divide by zero\n");
    > +if ( partial_status & SW_Denorm_Op )
    > +printk("SW: denormalized operand\n");
    > +if ( partial_status & SW_Invalid )
    > +printk("SW: invalid operation\n");
    > #endif /* DEBUGGING */

    Well, IMHO, the code was more readable and checkable in the initial
    version. I think this is one example of exceptions where code appearance
    is more important than style correctness.

    Regards,
    Willy



    \
     
     \ /
      Last update: 2008-01-29 00:47    [W:5.079 / U:0.120 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site