lkml.org 
[lkml]   [2008]   [Jan]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [GIT PATCH] driver core patches against 2.6.24


On Fri, 25 Jan 2008, Greg KH wrote:
>
> That's really wierd, I don't see that at all here just running with your
> 2.6.24 + my git tree and lots of USB drivers built into the kernel also
> (like ehci_hcd).

But do you use an initrd that tries to load the same driver too?

I'm too lazy to want to do my own initrd. I just use the prepackaged ones
and rely on the fact that my private kernel will refuse to load modules
that aren't meant for it anyway.

> $ cat /proc/sys/kernel/tainted
> 0

Mine says "2".

> $ uname -r
> 2.6.24-ge374a2bf-dirty
>
> Strange, I thought that the uname id would show the git version that you
> were running, but that doesn't show a valid id. But that's probably a
> different issue in the build system somewhere...

That *is* the git version you're running: e374a2bf.

The "-g" is for "git" and the "-dirty" is because you have some
non-checked-in changes in addition.

I works for me:

[torvalds@hp linux]$ git show --abbrev-commit -s --pretty=oneline e374a2bf
e374a2b... Kobject: fix coding style issues in kobject c files

so that looks like a valid version..

Linus


\
 
 \ /
  Last update: 2008-01-25 20:15    [from the cache]
©2003-2011 Jasper Spaans