lkml.org 
[lkml]   [2008]   [Jan]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH 012/196] nozomi driver
Date
Hi,

thanks for your feedback.

On Freitag 25 Januar 2008 09:31:25, you (Jan Engelhardt) wrote:
> On Jan 24 2008 23:09, Greg Kroah-Hartman wrote:
> >+/*
> >+ * nozomi.c -- HSDPA driver Broadband Wireless Data Card - Globe Trotter
> >+ *
> >+ * Written by: Ulf Jakobsson,
> >+ * Jan �erfeldt,
> ^
> Neither in ISO-8859-1 nor UTF-8 this position contains something meaningful.
> Mind to update to UTF-8?

fixed

> >+/*
> >+ * CHANGELOG
>
> Changelogs go into git, not files, at least that is what was mentioned
> time and again.

i removed them

> >+#ifdef __BIG_ENDIAN
> >+/* Big endian */
> >+
> >+struct toggles {
> >+ unsigned enabled:5; /*
> >+ * Toggle fields are valid if enabled is 0,
> >+ * else A-channels must always be used.
> >+ */
> >+ unsigned diag_dl:1;
> >+ unsigned mdm_dl:1;
> >+ unsigned mdm_ul:1;
> >+} __attribute__ ((packed));
>
> Probably just me, unsigned int is a good bit more explicit.
> The driver may also use a combined struct with
> BIG_ENDIAN_BITFIELD/LITTLE_ENDIAN_BIGFIELD (see e.g. linux/ip.h).

Here i agree with Stefan, especially as this also would only
make a difference for one (struct config_table) of those four structs
and there it would vastly decrease readability.

> >+/* Global variables */
> >+static struct pci_device_id nozomi_pci_tbl[] = {
> >+ {PCI_DEVICE(VENDOR1, DEVICE1)},
> >+ {},
> >+};
>
> The macros are only used once, could just as well substitute them
> by their real values.

Yes, but on the other hand now all those driver specific numbers
are grouped together in the beginning of nozomi.c and it also
could happen there once will appear other cards or models of it
that this nozomi driver could handle.

> >+/*
> >+ * Handle donlink data, ports that are handled are modem and diagnostics
> ^
> downlink

corrected

> >+static DEVICE_ATTR(card_type, 0444, card_type_show, NULL);
>
> While 0444 is probably never going to change its meaning, S_IRUGO comes
> into mind.

changed it to S_IRUGO

> >+/* just to discard single character writes */
> >+static void ntty_put_char(struct tty_struct *tty, unsigned char c)
> >+{
> >+ /* FIXME !!! */
> >+ DBG2("PUT CHAR Function: %c", c);
> >+}

Its just a misleading comment, but i changed it.

Besides that i also removed an error and a warning the current
checkpatch.pl now showed up ("trailing statments should be on next
line" and a "inline preferred over __inline-__").

Thanks,
Frank
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2008-01-25 13:49    [W:0.173 / U:2.380 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site