lkml.org 
[lkml]   [2008]   [Jan]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [Suspend2-devel] Reboot problem
Date
On Wednesday, 2 of January 2008, Christian Hesse wrote:
> On Wednesday 02 January 2008, Nigel Cunningham wrote:
> > Hi Christian.
> >
> > Christian Hesse wrote:
> > > On Tuesday 01 January 2008, Nigel Cunningham wrote:
> > >> Third, regarding the patch itself, I'm taking my time in working towards
> > >> the 3.0 release. We don't have any major bugs with 3.0-rc3 reported
> > >> [...].
> > >
> > > Well, I think I still have a bug, though it is possibly a mainline
> > > problem and it's not a showstopper. After a suspend/resume cycle the
> > > reboot does not work. The system hangs with "Rebooting system" (or
> > > similar). After that you have to hard reset the system, which is not
> > > really a problem as filesystems have been unmounted before. Reboot
> > > without a suspend cycle before and halt with and without suspend cycle
> > > work without problems.
> >
> > Just to clarify, do you mean rebooting after writing an image, or
> > shutting down and rebooting? It could be that there's some change to the
> > semantics in 2.6.24 that I haven't noticed yet.
>
> I speak about shutting down and rebooting. I have not used reboot after
> writing an image for a long time now. Will test what happens in this case.
>
> I had the issue before 2.6.24(-rc) already, thought I don't know whether there
> were times it worked. I use it way too seldom.

Well, this is similar to http://bugzilla.kernel.org/show_bug.cgi?id=6655 ,
which definitely is a mainline problem (still pending).

Greetings,
Rafael\


\
 
 \ /
  Last update: 2008-01-02 14:09    [from the cache]
©2003-2011 Jasper Spaans