lkml.org 
[lkml]   [2008]   [Jan]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
SubjectRe: [PATCH 4/5] x86: Add config variables for SMP_MAX
Ingo Molnar wrote:
> * Ingo Molnar <mingo@elte.hu> wrote:
>
>> and then it crashes with:
>>
>> [ 0.000000] Bootmem setup node 0 0000000000000000-000000003fff0000
>> [ 0.000000] KERN_NOTICE cpu_to_node(0): usage too early!
>> PANIC: early exception 06 rip 10:ffffffff81f77f30 error 0 cr2 f06f53
>> [ 0.000000] Pid: 0, comm: swapper Not tainted 2.6.24-rc8 #422
>> [ 0.000000]
>> [ 0.000000] Call Trace:
>> [ 0.000000] [<ffffffff81f76b4a>] ? setup_node_bootmem+0x1a0/0x1b8
>> [ 0.000000] [<ffffffff81f77f30>] ? acpi_scan_nodes+0x204/0x255
>> [ 0.000000] [<ffffffff81f77f30>] ? acpi_scan_nodes+0x204/0x255
>> [ 0.000000] [<ffffffff81f77103>] ? numa_initmem_init+0x343/0x471
>>

I *think* but have not been able to verify that this will fix the above panic:


--- a/arch/x86/mm/srat_64.c
+++ b/arch/x86/mm/srat_64.c
@@ -393,7 +393,7 @@ int __init acpi_scan_nodes(unsigned long
setup_node_bootmem(i, nodes[i].start, nodes[i].end);

for (i = 0; i < NR_CPUS; i++) {
- int node = cpu_to_node(i);
+ int node = early_cpu_to_node(i);
if (node == NUMA_NO_NODE)
continue;
if (!node_isset(node, node_possible_map))
The problem is that the x86 test tree kernel doesn't boot, even without my
changes. And the stack trace I don't think is correct.

Thanks,
Mike


\
 
 \ /
  Last update: 2008-01-20 02:17    [from the cache]
©2003-2011 Jasper Spaans