lkml.org 
[lkml]   [2008]   [Jan]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC][PATCH 3/5] add /dev/mem_notify device
On 1/16/08, Pavel Machek <pavel@ucw.cz> wrote:
> On Wed 2008-01-16 02:13:32, Marcelo Tosatti wrote:
> > On Wed, Jan 16, 2008 at 10:57:16AM +0900, KOSAKI Motohiro wrote:
> > > Hi Pavel
> > >
> > > > > err = poll(&pollfds, 1, -1); // wake up at low memory
> > > > >
> > > > > ...
> > > > > </usage example>
> > > >
> > > > Nice, this is really needed for openmoko, zaurus, etc....
> > > >
> > > > But this changelog needs to go into Documentation/...
> > > >
> > > > ...and /dev/mem_notify is really a bad name. /dev/memory_low?
> > > > /dev/oom?
> > >
> > > thank you for your kindful advise.
> > >
> > > but..
> > >
> > > to be honest, my english is very limited.
> > > I can't make judgments name is good or not.
> > >
> > > Marcelo, What do you think his idea?
> >
> > "mem_notify" sounds alright, but I don't really care.
> >
> > Notify:
> >
> > To give notice to; inform: notified the citizens of the curfew by
> > posting signs.
>
> I'd read mem_notify as "tell me when new memory is unplugged" or
> something. /dev/oom_notify? Plus, /dev/ names usually do not have "_"
> in them.

I don't think we should use oom in the name, since the notification is
sent long before oom.


\
 
 \ /
  Last update: 2008-01-16 12:53    [W:0.088 / U:0.644 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site