lkml.org 
[lkml]   [2008]   [Jan]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectSATA DOM is not identified by ata_piix module
Date
Hi,

I have a PQI Turbo SATA DOM. It works well under Windows. I installed it in
a SuperMicro motherboard, Intel 5000P chipset. The OS is Ubuntu 7.04, kernel
2.6.20-15. But the DOM is not appeared as a device node, and I found several
error messages in kernel log.

[   67.124299] ata2.00: qc timeout (cmd 0x91)
[   67.124306] ata2.00: failed to IDENTIFY (INIT_DEV_PARAMS failed,
err_mask=0x4)
[   67.124309] ata2: failed to recover some devices, retrying in 5 secs
[  102.258334] ata2.00: qc timeout (cmd 0x91)
[  102.258341] ata2.00: failed to IDENTIFY (INIT_DEV_PARAMS failed,
err_mask=0x4)
[  102.258344] ata2: failed to recover some devices, retrying in 5 secs
[  137.392654] ata2.00: qc timeout (cmd 0x91)
[  137.392661] ata2.00: failed to IDENTIFY (INIT_DEV_PARAMS failed,
err_mask=0x4)

Actually I also have a PQI IDE DOM, it have same error with Ubuntu 7.04 /
kernel 2.6.20-15. After I upgrade kernel to 2.6.22, the IDE DOM can work.
But as for SATA DOM, I have no luck this time. Even with the newest kernel,
2.6.23.14 and 2.6.24-rc7-git6, the problem still exists.
I also found an interesting matter. The Ubuntu 6.10, say kernel 2.6.15-28,
can identify both IDE DOM and SATA DOM. But due to other critical problem, I
can not go back to this old kernel.

What’s going on? The new kernel is even worse than old one. It seems the
problem is existing in the ata_piix driver.

Best regards,
Mao Rui



--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2008-01-15 11:15    [from the cache]
©2003-2011 Jasper Spaans