lkml.org 
[lkml]   [2007]   [Sep]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.6.23-rc4-mm1 - git-alsa.patch breaks audio on Dell Latitude D820
At Wed, 05 Sep 2007 15:46:34 -0400,
Valdis.Kletnieks@vt.edu wrote:
>
> On Fri, 31 Aug 2007 21:58:22 PDT, Andrew Morton said:
> > ftp://ftp.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.23-rc4/2.6.23-rc4-mm1/
>
> git-alsa.patch breaks audio on my laptop, worked fine in -rc3-mm1. Almost
> certainly bustification in the Intel HDA rewrite.
>
> Symptoms: alsamixer finds the chipset, can adjust the volumes and mute/unmute,
> and /usr/bin/play is able to write a .wav to the ALSA device without complaint.
> However, no sound actually comes out. Very "lights are on but nobody is home".
>
> Dell Latitude D820, lspci reports:
>
> 00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
> and alsamixer reports finding a "SigmaTel STAC9200"
>
> % grep HDA_ .config
> CONFIG_SND_HDA_INTEL=y
> # CONFIG_SND_HDA_HWDEP is not set
> CONFIG_SND_HDA_CODEC_REALTEK=y
> CONFIG_SND_HDA_CODEC_ANALOG=y
> CONFIG_SND_HDA_CODEC_SIGMATEL=y
> # CONFIG_SND_HDA_CODEC_VIA is not set
> # CONFIG_SND_HDA_CODEC_ATIHDMI is not set
> # CONFIG_SND_HDA_CODEC_CONEXANT is not set
> # CONFIG_SND_HDA_CODEC_CMEDIA is not set
> # CONFIG_SND_HDA_CODEC_SI3054 is not set
> CONFIG_SND_HDA_GENERIC=y
> # CONFIG_SND_HDA_POWER_SAVE is not set
>
> dmesg under -rc4-mm1:
> Advanced Linux Sound Architecture Driver Version 1.0.14 (Fri Jul 20 09:12:58 2007 UTC).
> ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 21 (level, low) -> IRQ 21
> hda_intel: position_fix set to 1 for device 1028:01cc
> ALSA device list:
> #0: HDA Intel at 0xefffc000 irq 506
>
> dmesg under -rc3-mm1:
>
> Advanced Linux Sound Architecture Driver Version 1.0.14 (Fri Jul 20 09:12:58 2007 UTC).
> ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 21 (level, low) -> IRQ 21
> hda_intel: position_fix set to 1 for device 1028:01cc
> ALSA device list:
> #0: HDA Intel at 0xefffc000 irq 506
>
> (Yes, they look the same to me, too...)
>
> I'd provide more info, if I had a clue what else to add...

First, check /proc/asound/card0/codec#* whether STAC9200 is identified
properly? If yes, check the mixer contents (at best, run
"alsactl -f somefile store"), see whether "Master Playback Volume" is
raised, "Master Playback Switch" unmuted, "Front..." raised/unmuted,
and "PCM ..." raised/unmuted, etc.

If this still doesn't work, try to give model=ref option to
snd-hda-intel. If it still not OK, please try bi-sect of
git.kernel.org/perex/alsa.git mm branch...


Takashi
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2007-09-05 22:15    [from the cache]
©2003-2011 Jasper Spaans