[lkml]   [2007]   [Sep]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [RFC] New kernel-message logging API
    On 9/23/07, Joe Perches <> wrote:
    > On Sat, 2007-09-22 at 21:27 +0200, Vegard Nossum wrote:
    > > #define kprint(fmt, ...)
    > Good ideas. Perhaps a prefix of klog or kp_ instead?
    > Given the number of 80 column zealots, character naming length matters.

    I don't know. Compare the following two lines:

    printk(KERN_INFO "Message.\n");

    By dropping the lengthy macro (it's not like it's going to change
    while we're running anyway, so why not make it a part of the function
    name?) and the final newline, we actually end up with a net decrease
    in line length.

    I thought it would be nice to have something that looks familiar,
    since that would ease an eventual transition. klog is a valid
    alternative, but isn't kp a bit cryptic?

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2007-09-23 10:41    [W:0.020 / U:4.700 seconds]
    ©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site