lkml.org 
[lkml]   [2007]   [Aug]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
SubjectRe: ALPS touchpad with new Dell not recognised
Hi LKML,
Thanks to Vojtech for some advice, I finally got something happening
with this. Turns out I had to add support for a new model in alps.c,
the attached file does this successfully for my laptop. It'd be nice to
have others test it, but I am yet to find anyone else who has this same
laptop, with the same mouse issues I have.

With this patch, I now get a functioning touchpad, including side
scrolling, circle scrolling, corner taps etc. However, I did have to
ramp the configuration numbers up significantly from my old Thinkpad
with its synaptics touchpad. Minspeed is now 0.8 and maxspeed is 10.
Also the VertScrollDelta is 10. I don't know whether these numbers are
crazy high, or just normal for the Alps though.



--- drivers/input/mouse/alps.c.old 2007-07-31 21:42:37.000000000 +1000
+++ drivers/input/mouse/alps.c 2007-08-04 21:45:43.000000000 +1000
@@ -53,6 +53,7 @@
{ { 0x20, 0x02, 0x0e }, 0xf8, 0xf8, ALPS_PASS | ALPS_DUALPOINT }, /* XXX */
{ { 0x22, 0x02, 0x0a }, 0xf8, 0xf8, ALPS_PASS | ALPS_DUALPOINT },
{ { 0x22, 0x02, 0x14 }, 0xff, 0xff, ALPS_PASS | ALPS_DUALPOINT }, /* Dell Latitude D600 */
+ { { 0x73, 0x02, 0x50 }, 0x4f, 0x4f, ALPS_FW_BK_1 } /* Dell Vostro 1400 */
};

/*
\
 
 \ /
  Last update: 2007-08-04 14:19    [W:0.069 / U:1.348 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site