lkml.org 
[lkml]   [2007]   [Aug]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: Trouble booting with new 2.6.22.3 kernel
Date
On Tuesday 21 August 2007 22:19:13 you wrote:
> Hello, I am running Kubuntu 7.04 on a mac mini (specs attached via
> info.html). For learning purposes I am trying to custom build a
> 2.6.22.3 kernel from source and boot from it. My plan was to use the
> distributions .config file (and I specified the settings for options
> that were added since the last kernel included with Kubuntu which is
> (and is what I have now reverted to) Linux hexstar-desktop
> 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686 GNU/Linux).
> I have attached the .config file used in the building of the 2.6.22.3
> kernel. Below is the error:
>
> Starting up...
> Uncompressing Linux... Ok, booting the kernel.
> [ 32.227452] i8042.c: No controller found
> [ 32.228426] Kernel panic - not syncing: VFS: Unable to mount root fs
> on unknown-block(0,0)
>
> That is the correct block however and it is of ext3 format. I have
> made sure that the ext3 module is built into the kernel and have tried
> it as a module and both times I get the same error. I am not sure why
> it can't find the controller? Does my controller not have support in
> the latest kernel?
>
> Please CC me replies to this post, thanks! :)

Make sure your IDE/SATA driver is compiled in unless you are using an
initramfs image.

Regards,
ismail

--
Perfect is the enemy of good
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2007-08-21 21:29    [W:0.068 / U:6.892 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site