lkml.org 
[lkml]   [2007]   [Aug]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectALPS touchpad with new Dell not recognised
I've got a Dell Vostro 1400 here, which according to the Windows drivers
has an ALPS touchpad that I'm working on. It has PS/2 pass through,
which means I can move the pointer around. It also picks up (via
hardware I assume) quick double-taps as click-and-drag. It however,
doesn't do multi-finger taps for middle and right mouse button. It also
doesn't do side scrolling, which is the big one for me.

/proc/bus/inputs/devices lists the mouse as
I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 Generic Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/class/input/input20
H: Handlers=mouse0 event4
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

I enabled debugging in the alps.c driver. My touchpad "passes" the E6
test, but the E7 test it returns 0x73, 0x2, 0x50. I've tried adding a
new model to the alps_model_info structure, with these numbers.
This made it be detected as an "Alps", but the behaviour was very
erratic, and kernel messages talked about the GlidePoint lost sync at
byte 1.

I'm not too familiar with the Alps driver, so I don't know exactly how
the byte0 or mask0 variables affect things. I tried 0xff and 0xf8 as
they were two common options.

Is anyone familiar with the Alps driver, and able to help me work out
how to get this touchpad working?


William
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2007-08-01 09:59    [W:0.087 / U:11.168 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site