[lkml]   [2007]   [Jul]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: 2.6.23-rc1: no setup signature found...
    Borislav Petkov wrote:
    > Right, this was too easy to be true. I now did:
    > qemu -hda /dev/hda -snapshot
    > and booted from the hd using the installed grub and the same kernel and it
    > _didn't_ boot showing again "no setup signature found... "

    Okay, so it's an algorithmic problem. This is quite important to know.

    Is /boot a separate partition on your disk by any chance? Either way,
    this means we can use qemu to debug this, which will make it a lot easier.

    This is what I'd like you to do next:

    - run qemu in one window with the -S -s options.
    - in another window, do:

    target remote localhost:1234
    set architecture i8086
    disp/i ($cs << 4)+$eip
    br *0x10200
    br *0x20200
    br *0x30200
    br *0x40200
    br *0x50200
    br *0x60200
    br *0x70200
    br *0x80200
    br *0x90200

    # ... hopefully you're now stopped at a jump instruction
    p/x $ds

    # Hopefully this is showing, say, 0x9000 if you're stopped
    # at 0x90200

    # Where X is the first digit of the address stopped at:
    dump memory setup.dump 0xX0000 0xX8000

    Please send me setup.dump plus your vmlinuz file.


    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2007-07-29 15:53    [W:0.042 / U:0.208 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site