[lkml]   [2007]   [May]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: RFC: kconfig select warnings bogus?
On Sun, May 20, 2007 at 05:06:33AM +0530, Satyam Sharma wrote:
> On 5/20/07, Adrian Bunk <> wrote:
>> Consider ATARI_KBD_CORE was used by 20 drivers.
>> Using select for such not user visible helper variables is a really nice
>> thing, and much more readable (and therefore much less likely to contain
>> bugs) than dependencies with tons of "||"'s.
> Well, the "default .. if .." kind of idiom is fairly common (I could say
> almost standard), in arch/.../config's. It's been used for some time,
> and for several symbols over there. But you're right that if 20 drivers
> used ATARI_KBD_CORE, we'd get tons of ugly "||"'s there, so
> perhaps we do need some kind of fix for this.

And the fix is to use select.

Compare the handling of options like IRQ_CPU in arch/mips/Kconfig in
current kernels with the handling in kernel 2.6.0 .

Or as an exercise, change drivers/net/Kconfig to no longer use
"select MII". When you are finished, ensure that you are handling it
properly although the option is user visible...

There are cases where "default .. if .." is the right idiom, but there
are also cases where "select" is the right idiom. And for helper code
like ATARI_KBD_CORE, "select" is the right idiom.



"Is there not promise of rain?" Ling Tan asked suddenly out
of the darkness. There had been need of rain for many days.
"Only a promise," Lao Er said.
Pearl S. Buck - Dragon Seed

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2007-05-20 01:51    [W:0.190 / U:1.848 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site