[lkml]   [2007]   [May]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: 2.6.22-rc1 killed my ext3 filesystem cleanly unmounted
    On Fri, May 18, 2007 at 04:20:39PM +0200, Jesper Juhl wrote:
    > On 18/05/07, Martin Mokrejs <> wrote:
    > > Hi,
    > > I just tried the 2.6.22-r1 candidate to test whether some bug I have
    > > hit in the past still exists. I did use so far. So, I have
    > > cleanly rebooted to use the new kernel, after the machine came up I
    > > tried to mess with the bug, and had to reboot again to play with kernel
    > > commandline parameters. Unfortunately, on the next reboot fsck was
    > > schedules on my filesystem after 38 clean mounts. :( And the problem
    > > started. The fsck found some unused inodes, but probably did not know
    > > where do they belong to, but it deleted them automagically. Finally, the
    > > fsck died because it cannot fine some '..' entry.
    > >
    > How do you know that the corruption was caused by 2.6.21-rc1 ?
    > Isn't it possible that the corruption was created by an earlier
    > kernel, but only detected when a forced fsck was run - which just
    > happened to be while you were running 2.6.21-rc1 ...
    > My point is that, as far as I can see, there's nothing tying
    > 2.6.21-rc1 specifically to this corruption... or?

    You might be right, but I thought maybe more probably is the cause in kernel
    as that is what I have changed recently. ;) Or maybe someone can at leats say
    "No, no changes to be considered between and 2.6.22-rc1.". ;)

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2007-05-18 16:39    [W:0.022 / U:1.628 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site