[lkml]   [2007]   [Apr]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: Performance Stats: Kernel patch
    William Lee Irwin III wrote:

    >On Sun 2007-04-15 03:21:57, William Lee Irwin III wrote:
    >>>nvcsw and nivcsw are conventional variable names for these quantities.
    >On Sun, Apr 15, 2007 at 08:10:24PM +0000, Pavel Machek wrote:
    >>I can't decipher them and would not want users see them in /proc.
    >>Would nonvoluntary_ctxt_switch be that much worse?
    >I'm not too attached to a particular name. I just think that the
    >traditional counter names should pass readability/etc. criteria on
    >account of the very strong historical precedent. I'd consider more
    >verbose affairs for the sake of putative legibility as equivalent
    >in quality. Maybe that means others voting for the more verbose
    >names should result in an aggregate decision in favor of verbosity.
    >-- wli
    The standard /proc output is:
    root@ cat /proc/$$/status
    Name: bash
    State: S (sleeping)
    SleepAVG: 88%
    Tgid: 836
    Pid: 836
    PPid: 1
    TracerPid: 0
    Uid: 0 0 0 0
    Gid: 0 0 0 0
    FDSize: 256
    Groups: 0 1 2 4
    VmPeak: 2360 kB
    VmSize: 2360 kB
    VmLck: 0 kB
    VmHWM: 1400 kB
    VmRSS: 1400 kB
    VmData: 196 kB
    VmStk: 88 kB
    VmExe: 564 kB
    VmLib: 1412 kB
    VmPTE: 12 kB
    Threads: 1
    SigQ: 0/1024
    SigPnd: 0000000000000000
    ShdPnd: 0000000000000000
    SigBlk: 0000000000010000
    SigIgn: 0000000000384004
    SigCgt: 000000004b813efb
    CapInh: 0000000000000000
    CapPrm: 00000000fffffeff
    CapEff: 00000000fffffeff

    I can't say that "Nvcsw" and "Nivcsw" is something less verbose as
    output above.
    It is more usual so it is more clear for you. But if you need this counters
    you should know what are they and how to use them.

    As for me "nonvoluntary_ctxt_switch" and "voluntary_ctxt_switch" is more
    and it is not big deal to change names. But I think that information about
    this counters and verbose name should be in user space tools, like ps.

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2007-04-16 11:27    [W:0.021 / U:44.872 seconds]
    ©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site