[lkml]   [2007]   [Mar]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [patch 03/26] Xen-paravirt_ops: use paravirt_nop to consistently mark no-op operations

* Jeremy Fitzhardinge <> wrote:

> Add a _paravirt_nop function for use as a stub for no-op operations,
> and paravirt_nop #defined void * version to make using it easier
> (since all its uses are as a void *).
> This is useful to allow the patcher to automatically identify noop
> operations so it can simply nop out the callsite.

Acked-by: Ingo Molnar <>

> +void _paravirt_nop(void);
> +#define paravirt_nop ((void *)_paravirt_nop)

but only as a cleanup of the current open-coded (void *) casts. My
problem with this is that it loses the types. Not that there is much to
check for, but still, this adds some assumptions about how function
calls look like.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2007-03-16 10:47    [W:0.413 / U:2.016 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site