lkml.org 
[lkml]   [2007]   [Mar]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    SubjectRe: netconsole system freeze when cable unplugged
    From
    Date
    Simon Arlott <simon@fire.lp0.eu> writes:

    > On 09/03/07 20:42, Francois Romieu wrote:
    > > Simon Arlott <simon@fire.lp0.eu> :
    > >> When I unplug the cable the system just stops responding to
    > >> anything, at all. No message is printed to the console when the
    > >> cable is plugged back in.
    > > rtl8139_interrupt (spin_lock(&tp->lock))
    > > -> rtl8139_weird_interrupt
    > > -> rtl_check_media
    > > -> mii_check_media (printk(KERN_INFO "%s: link down\n", ...))
    > > [netpoll stuff here]
    > > -> rtl8139_poll_controller
    > > -> rtl8139_interrupt
    > > *deadlock*
    > > See below for my random stuff of the day. Feel free to open a PR at
    > > bugzilla.kernel.org if the issue does not go away.
    >
    > The patch doesn't fix it, nothing changes. I'm not sure how this can
    > be debugged if printk won't work...

    earlyprintk can be called directly (early_printk()) and should
    work. It won't log over the network of course.

    -Andi
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2007-03-10 13:41    [W:0.022 / U:29.072 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site