lkml.org 
[lkml]   [2007]   [Feb]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 01/22] filesystem helpers for custom 'struct file's
On Fri, 09 Feb 2007 14:53:29 -0800
Dave Hansen <hansendc@us.ibm.com> wrote:

> +/*
> + * Note: This is a crappy interface. It is here to make
> + * merging with the existing users of get_empty_filp()
> + * who have complex failure logic easier. All users
> + * of this should be moving to alloc_file().
> + */
> +int init_file(struct file *file, struct vfsmount *mnt,
> + struct dentry *dentry, mode_t mode,
> + const struct file_operations *fop)

crappy name too ;) At least two filesystems have defined their own
static-scope init_file() and so they'll explode if they somehow maange
to include file.h.

I guess we can cross that bridge when we fall off it, but sometime it might be
prudent to do s/init_file/configfs_init_file/ and ditto sysfs_init_file.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2007-02-10 00:21    [W:0.199 / U:0.176 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site