[lkml]   [2007]   [Feb]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
Subject[linux-cifs-client] Re: SMB support still missing?

I tried the various suggestions from the last mails, but nothing of
that worked. --verbose did not return anything useful. It's the kernel
module that returns -EHOSTDOWN.


Eventually I found out that this one works:

mount.cifs //cl0/c /mnt -o servernetbiosname=CL0

So what did I change? Casing. Note that "CL0" is entirely uppercase.
Although strange, it actually coincides with how LANMAN works.
Everything is uppercased in lanman, hostnames, usernames, heck, even
plaintext passwords (samba-smbd has a good time trying a ton of
combinations in such setups).

No other options like sec=none or thelike were needed. Login as
anonymous worked directly.

Please consider updating the cifs kernel module to account for the LM
oddity of uppercasing things. (Then, smbfs can finally be ripped out I

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2007-02-09 01:19    [W:0.038 / U:0.048 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site