[lkml]   [2007]   [Feb]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
Subjecta quick survey: "FIELD_SIZEOF" or "MEMBER_SIZE"?

pardon the interruption but, once upon a time, we were discussing
cleaning up code to use the kernel.h-defined macro "FIELD_SIZEOF".

some folks suggested that the macro name itself was kind of awkward
as it didn't fit the pattern of "ARRAY_SIZE" defined in that same
header file.

because of a name clash, "FIELD_SIZE" is not available, but there
was a suggestion of, uh, "MEMBER_SIZE". :-)

so, really, those are the two viable choices -- stick with the
current name of FIELD_SIZEOF, or switch to MEMBER_SIZE. switching is
not a big deal since no one (at least, no one in the current tree)
uses FIELD_SIZEOF as it is, so it's not as if it would be a disruptive
change in the slightest.



Robert P. J. Day
Linux Consulting, Training and Annoying Kernel Pedantry
Waterloo, Ontario, CANADA
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2007-02-03 09:03    [W:0.024 / U:2.896 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site