lkml.org 
[lkml]   [2007]   [Feb]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [BUG/WARN] Error initialising drivers in PCI
Date

On Monday 19 February 2007 05:00, Ian McDonald wrote:
> On 2/19/07, Bartlomiej Zolnierkiewicz <bzolnier@gmail.com> wrote:
> > Ian, you have an PATA controller so there is no need to use ata_piix.
> > Just disabling ata_piix should workaround the issue.
> >
> OK. I have done this and the message goes away in boot logs. As you
> say I don't need the old drivers anymore.

No, I said that you don't need the new drivers anymore as the warning
is caused by libata using resource hacks. 8)

Anyway both drivers (old and new) work fine, just mixing them have issues.

> If you want me to test any fixes so both can coexist without throwing
> a warning then just drop me a line.

Tejun, this needs to be fixed unless Jeff pushes resources hack
removal patch(es) before 2.6.21 (then it will fix by itself).

Thanks,
Bart
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2007-02-19 12:45    [W:0.035 / U:4.672 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site