[lkml]   [2007]   [Feb]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: Regress for 8139too in 2.6.20
> On Sun, 11 Feb 2007 18:03:33 -0600 Larry Finger <> wrote:
> In kernel version 2.6.20, my network interface, a Uniden PCN 300 PCMCIA card that uses the 8139too
> driver fails to initialize with Yenta and 8139too as modules. It worked correctly in 2.6.19. Using
> git bisect, the bad commit is shown below:
> finger@sonylap:~/linux-2.6> git bisect good
> 8d610dd52dd1da696e199e4b4545f33a2a5de5c6 is first bad commit
> commit 8d610dd52dd1da696e199e4b4545f33a2a5de5c6
> Author: Linus Torvalds <>
> Date: Mon Dec 11 12:12:04 2006 -0800
> Make sure we populate the initroot filesystem late enough
> We should not initialize rootfs before all the core initializers have
> run. So do it as a separate stage just before starting the regular
> driver initializers.
> Signed-off-by: Linus Torvalds <>
> :040000 040000 12bc13def90d15921d41d2b285854b3e157a970f f936e01f6b1b2b75478484861d34e81830c73860 M
> include
> :040000 040000 5673719c3f6b47b329cfc9554c112077634a9b19 9c2e768964af1500d62849836b9f8e801fe7f29e M
> init
> If Yenta is built into the kernel, rather than a module, it works again with 2.6.20.

That's a bit surprising - the initcall levels don't affect modules.
Presumably something went wrong in core kernel which later caused yenta
and/or 8139too to fail.

Have you tried diffing the before- and after-dmesgs to see if that particular
commit has caused any interesting differences?

And are you able to test any other cardbus devices to see whether it's
specific to 8139too?

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2007-02-12 23:11    [W:0.052 / U:0.052 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site