lkml.org 
[lkml]   [2007]   [Nov]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    SubjectRe: [i2c] [2.6 patch] some overdue I2C driver removal
    From
    On Wed, Nov 28, 2007 at 12:43:00PM -0500, Jon Smirl wrote:
    > Hasn't their been a one year notice that these drivers were going to
    > be removed? How about removing them and putting them into a tarball on
    > the i2c web site with a note explaining about how they need to be
    > updated to use the gpio driver? Then if someone really wants to use
    > the old drivers they can use them out of tree.

    Why remove a working driver? Who gets to decide that everyone must go
    use this gpio api based system that isn't yet supported by all
    platforms? If someone thinks the old drivers should be replaced by new
    ones using the new GPIO API then they should go implement it, and then
    when it works they can remove the old one. You can't just declare that
    you think the old one sucks and should be removed and if anyone else
    cares they should go make a working driver to replace it.

    --
    Len Sorensen
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2007-11-28 20:07    [W:0.026 / U:30.492 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site