lkml.org 
[lkml]   [2007]   [Nov]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.6.24-rc2-mm1
On Nov 15, 2007 5:27 AM, Kay Sievers <kay.sievers@vrfy.org> wrote:
> On Wed, 2007-11-14 at 20:19 +0100, Jiri Kosina wrote:
> > On Wed, 14 Nov 2007, Kay Sievers wrote:
> >
> > > Could it be an init-order problem, where something tries to use the
> > > block subsystem? Before it is initialized with:
> > > block/genhd.c :: subsys_initcall(genhd_device_init);
> > > If that's the case, we have an old bug that nobody noticed with static
> > > structures, which are zeroed that time, but definitely not properly
> > > initialized. I'll try to build loop non-modular now, and see if that
> > > makes the bug appear here.
>
> > my .config with which I reproduc this on 2.6.24-rc2-mm1 reliably can be
> > obtained from http://www.jikos.cz/jikos/junk/.config
>
> Hmm, that config doesn't do anything here, and if I make it boot, it
> does not show the bug.
>
> Could you possibly enable kobject debugging and see if that exposes
> something, maybe something goes wrong with the kset refcount and it gets
> released while in use.
>
Hi,
I would do that.
BTW, The bug report as EIP at __list_add with CONFIG_DEBUG_LIST=y

Regards
dave
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2007-11-15 02:03    [from the cache]
©2003-2011 Jasper Spaans