lkml.org 
[lkml]   [2007]   [Oct]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    From
    Subject[PATCH 53/75] sysfs: fix comments of sysfs_add/remove_one()
    Date
    From: Tejun Heo <htejun@gmail.com>

    sysfs_add/remove_one() now link and unlink the target dirent into and
    from the children list. Update comments accordingly.

    Signed-off-by: Tejun Heo <htejun@gmail.com>
    Acked-by: Cornelia Huck <cornelia.huck@de.ibm.com>
    Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
    ---
    fs/sysfs/dir.c | 10 +++-------
    1 files changed, 3 insertions(+), 7 deletions(-)

    diff --git a/fs/sysfs/dir.c b/fs/sysfs/dir.c
    index 5d95aa8..fc615ee 100644
    --- a/fs/sysfs/dir.c
    +++ b/fs/sysfs/dir.c
    @@ -410,10 +410,8 @@ void sysfs_addrm_start(struct sysfs_addrm_cxt *acxt,
    * @sd: sysfs_dirent to be added
    *
    * Get @acxt->parent_sd and set sd->s_parent to it and increment
    - * nlink of parent inode if @sd is a directory. @sd is NOT
    - * linked into the children list of the parent. The caller
    - * should invoke sysfs_link_sibling() after this function
    - * completes if @sd needs to be on the children list.
    + * nlink of parent inode if @sd is a directory and link into the
    + * children list of the parent.
    *
    * This function should be called between calls to
    * sysfs_addrm_start() and sysfs_addrm_finish() and should be
    @@ -453,9 +451,7 @@ int sysfs_add_one(struct sysfs_addrm_cxt *acxt, struct sysfs_dirent *sd)
    * @sd: sysfs_dirent to be added
    *
    * Mark @sd removed and drop nlink of parent inode if @sd is a
    - * directory. @sd is NOT unlinked from the children list of the
    - * parent. The caller is repsonsible for removing @sd from the
    - * children list before calling this function.
    + * directory. @sd is unlinked from the children list.
    *
    * This function should be called between calls to
    * sysfs_addrm_start() and sysfs_addrm_finish() and should be
    --
    1.5.3.4
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2007-10-13 00:53    [W:6.669 / U:0.300 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site