Messages in this thread |  | | Date | Tue, 30 Jan 2007 17:09:10 -0600 | | From | Maynard Johnson <> | | Subject | Re: [Cbe-oss-dev] [RFC, PATCH 4/4] Add support to OProfile for profiling Cell BE SPUs -- update |
| |
Christoph Hellwig wrote:
> On Tue, Jan 30, 2007 at 06:53:50PM +1100, Benjamin Herrenschmidt wrote: > >>>>+/* Defines used for sync_start */ >>>>+#define SKIP_GENERIC_SYNC 0 >>>>+#define SYNC_START_ERROR -1 >>>>+#define DO_GENERIC_SYNC 1 >>>>+ >>>>+typedef struct vma_map >>>>+{ >>>>+ struct vma_map *next; >>>>+ unsigned int vma; >>>>+ unsigned int size; >>>>+ unsigned int offset; >>>>+ unsigned int guard_ptr; >>>>+ unsigned int guard_val; >>>>+} vma_map_t; >> >>I haven't had time to look in details yet but in that context, what does >>"vma" stands for ? There's already an important vm data structure in >>linux routinely called "vma" and thus I suspect this is a poor naming >>choice as it will cause confusion. > > > It looks like it actually is dealing with vma to me. But then again: > > - please don't use typedefs for structures > - there might be a more descriptive name for this than just vma_map Yes, I'll come up with some (hopefully) better name. > > ------------------------------------------------------------------------- > Take Surveys. Earn Cash. Influence the Future of IT > Join SourceForge.net's Techsay panel and you'll get the chance to share your > opinions on IT & business topics through brief surveys - and earn cash > http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV > _______________________________________________ > oprofile-list mailing list > oprofile-list@lists.sourceforge.net > https://lists.sourceforge.net/lists/listinfo/oprofile-list
- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
|  |