lkml.org 
[lkml]   [2007]   [Jan]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    Subjectusb2 external disk not recognized if connected during boot, but recognized if not connected during boot
    On a small Celeron-based appliance, Usb2 disk is not recognized *if*
    it is connected during kernel boot.
    But if not connected during boot, and I connect it later, it is
    recognized and works ok.
    I tried various 2.6.16, 17 and 18 kernels, both modular, and
    all-static, with the same result.
    What can this be.
    This is ehci controller. Can it be problematic Irq assignments on the
    motherboard ?
    Btw, during boot, access lights go on forever on the Usb drive. Couple
    of kernels are stuck
    at this point. Most kernels go through, but disk is still not
    recognized. If I disconnect and re-connect usb drive later, then it is
    never recognized (if it was connected earlier during boot). Again, if
    the disk was not connected during boot, all kernels recognize it and
    work with it.

    Thank
    Yakov
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2007-01-25 09:51    [W:0.025 / U:151.428 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site