[lkml]   [2007]   [Jan]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: change strip_cache_size freeze the whole raid

    On Mon, 22 Jan 2007, kyle wrote:

    > Hi,
    > Yesterday I tried to increase the value of strip_cache_size to see if I can
    > get better performance or not. I increase the value from 2048 to something
    > like 16384. After I did that, the raid5 freeze. Any proccess read / write to
    > it stucked at D state. I tried to change it back to 2048, read
    > strip_cache_active, cat /proc/mdstat, mdadm stop, etc. All didn't return back.
    > I even cannot shutdown the machine. Finally I need to press the reset button
    > in order to get back my control.
    > Kernel is x86-64, running at AMD Athlon3000+, 2GB Ram, 8 x Seagate
    > 8200.10 250GB HDD, nvidia chipset.
    > cat /proc/mdstat (after reboot):
    > Personalities : [raid1] [raid5] [raid4]
    > md1 : active raid1 hdc2[1] hda2[0]
    > 6144768 blocks [2/2] [UU]
    > md2 : active raid5 sdf1[7] sde1[6] sdd1[5] sdc1[4] sdb1[3] sda1[2] hdc4[1]
    > hda4[0]
    > 1664893440 blocks level 5, 512k chunk, algorithm 2 [8/8] [UUUUUUUU]
    > md0 : active raid1 hdc1[1] hda1[0]
    > 104320 blocks [2/2] [UU]
    > Kyle
    > -
    > To unsubscribe from this list: send the line "unsubscribe linux-raid" in
    > the body of a message to
    > More majordomo info at

    Yes, I noticed this bug too, if you change it too many times or change it
    at the 'wrong' time, it hangs up when you echo numbr >

    Basically don't run it more than once and don't run it at the 'wrong' time
    and it works. Not sure where the bug lies, but yeah I've seen that on 3
    different machines!


    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2007-01-22 14:43    [W:0.020 / U:70.440 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site