lkml.org 
[lkml]   [2006]   [Sep]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [xfs-masters] Re: [PATCH 2.6.18-rc4-mm3 2/2] fs/xfs: Converting into generic boolean
Nathan Scott wrote:

>On Tue, Sep 05, 2006 at 02:47:02PM +0200, Richard Knutsson wrote:
>
>
>>Just the notion: "your" guys was the ones to make those to boolean(_t),
>>
>>
>
>Sort of, we actually inherited that type from IRIX where it is
>defined in <sys/types.h>.
>
>
Oh, ok

>>>"int needflush;" is just as readable (some would argue moreso) as
>>>"bool needflush;" and thats pretty much the level of use in XFS -
>>>
>>>
>>>
>>How are you sure "needflush" is, for example, not a counter?
>>
>>
>
>Well, that would be named "flushcount" or some such thing. And you
>would be able to tell that it was a counter by the way its used in
>the surrounding code.
>
>
True, thinking more of when you have a quick look at the headers, but
"flushcount" would be a more logical name in such a case.

>This discussion really isn't going anywhere useful; I think you need
>to accept that not everyone sees value in a boolean type. :)
>
>
Well, can you blame me for trying? ;)
But the more important thing is to clean up the boolean-type and
FALSE/TRUE mess in the kernel.

>cheers.
>
>
Thank you for your time and happy coding :)

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-09-06 02:19    [W:0.030 / U:1.212 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site