lkml.org 
[lkml]   [2006]   [Sep]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: 2.6.18-git9 wireless fixes break ipw2200 association to AP with WPA
From
On Fri, Sep 29, 2006 at 10:40:29PM +0200, Alessandro Suardi wrote:
> On 9/29/06, John W. Linville <linville@tuxdriver.com> wrote:
> >On Fri, Sep 29, 2006 at 09:25:53PM +0200, Alessandro Suardi wrote:
> >> Dell Latitude D610, FC5-latest, ipw2200 configured to associate
> >> with a D-Link DSL-G604T (combo of router/ADSL modem/802.11g AP).
> >>
> >> 2.6.18-git8 (plus semaphore.h) is ok
> >> -git9, -git10, -git11 fail to associate
> >> -git11 with reverted wireless changes is ok
> >>
> >> Attaching diff of what I reverted in -git11 to make it work again.
> >>
> >> wpa_supplicant log of failing session available upon request.
> >
> >It looks like you reverted the WE-21 stuff. Is your wireless-tools
> >package up to date?
>
> Well, that's the latest I get under FC5:
>
> [asuardi@sandman ~]$ rpm -q wireless-tools
> wireless-tools-28-0.pre13.5.1

That's too old, the cutoff is 27-pre15.

> but indeed (-git11 minus the reverts) iwconfig says
>
> [asuardi@sandman ~]$ iwconfig eth1
> Warning: Driver for device eth1 has been compiled with version 21
> of Wireless Extension, while this program supports up to version 19.
> Some things may be broken...

That's exactly the point of this warning (some distro like to
kill it), I think it spells pretty clearly what's wrong. Don't say I
did not warn you...

> If you have suggestions about either upgrading wireless-tools
> from a non-FC5 repository or narrowing down the reverts, I'm
> up for giving them a go :)

If you run a custom kernel, I think you won't see any problems
running a custom version of Wireless Tools. They are available on my
web site, pretty easy to install, and have minimal
implications. Usually distro do no customisation of my tools.
On the other hand, FC6, which is in beta, contains already the
proper version of the tools. I have been monitoring the various distro
in the last few months before sending those WE-21 patches, and all
major distro have WT-28 in the pipeline.
Actually, you might be able to install the wireless-tools RPM
of FC6 of FC-dev onto your FC5.

> Thanks, ciao,
>
> --alessandro

Have fun...

Jean
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-09-29 23:31    [from the cache]
©2003-2011 Jasper Spaans