lkml.org 
[lkml]   [2006]   [Sep]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 5 of 11] XFS: Use SEEK_{SET, CUR, END} instead of hardcoded values
On Mon, Sep 18, 2006 at 11:30:35AM +0100, David Howells wrote:
> David Chinner <dgc@sgi.com> wrote:
>
> > The hard coded values used in xfs_change_file_space() are documented as part
> > of the API to the userspace functions that use this interface in xfsctl(3).
>
> Hmmm... that's a good point. I think you're right on this account, and so the
> comments in:
>
> case 0: /*SEEK_SET*/
> break;
> case 1: /*SEEK_CUR*/
> bf->l_start += offset;
> break;
> case 2: /*SEEK_END*/
> bf->l_start += ip->i_d.di_size;
> break;
>
> should be stripped off as they are not exactly correct.

Sure, they're not _exactly_ the same as seek semantics, but the
comment is informative enough to tell you what the magic numbers
are supposed to mean as you read the code.

If you really want to strip these out these comments, can you please
replace them with a new comment that documents the magic number
behaviour?

Cheers,

Dave.
--
Dave Chinner
Principal Engineer
SGI Australian Software Group
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-09-19 06:05    [W:0.065 / U:0.064 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site