lkml.org 
[lkml]   [2006]   [Sep]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: thinkpad 360Cs keyboard problem
    On Tue, 12 Sep 2006, Dmitry Torokhov wrote:

    > On 9/12/06, Piotr Gluszenia Slawinski <curious@zjeby.dyndns.org> wrote:
    >> On Tue, 12 Sep 2006, Dmitry Torokhov wrote:
    >>
    >> > On 9/11/06, Piotr Gluszenia Slawinski <curious@zjeby.dyndns.org> wrote:
    >>
    >> > > kernel boots up fine, but keyboard is totally messed up,
    >> > > and locks up after some tries of use.
    >> >
    >> > Could you try describing the exact issues with the keyboard? Missing
    >> > keypresses, wrong keys reported, etc?
    >>
    >> with prink enabled it prints series of 'unknown scancode'
    >> and keys are randomly messed up, and it changes, so like pressing b
    >> results with n, then space, then nothing at all.
    >> after some tries keyboard locks up completely.
    >>
    >
    > Are you loading a custom keymap by any chance? Could I please see
    > dmesg with "i8042.debug log_buf_len=131072"?

    no custom keymaps . init=/bin/bash :d
    uhm, i don't get what you mean by this dmesg syntax :o
    i should probably attach serial conole and send you whole output,
    as now (as keyboard is unuseable) i can't scroll screen.

    btw. serio: i8042 KBD port at 0x60,0x64 irq 1
    is found.
    also
    input: AT Raw Set 2 keyboard as /class/input/input1
    is reported

    ah, i use gcc-4.1.1 to compile kernel .


    -------------------- stuff below might be result of my ignorance

    i just checked 2.2.27 kernel. it behaves quite identical to 2.4.33.3,
    just after 'freeing unused kernel memory' it touches disk , and just
    sits there. kepresses are echoed, and keyboard output is
    ok. i can reboot it by ctrl-alt-delete too .
    when i boot it with 'fosh' shell commandline appears, but trying
    to use any tool like bash, ls , etc results with signal 11.
    tools are statically compiled against glibc-2.4 (compiled for 486 cpu
    on gentoo)
    busybox works fine.

    on 2.4.33.3 kernel Xvesa (from kdrive package) complains
    'set_thread_area failed when setting up thread-local storage'

    cardmgr works fine aswell...(though was linked against different glibc)
    i guess there is some problem with math emulation and glibc,
    as on 2.6.18 everything works just fine.

    i recall few years ago i tried to make 386SX work on 2.4.20 , and
    there were problems with math emulation (some apps worked, some not)






    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2006-09-12 23:25    [W:0.024 / U:29.912 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site