[lkml]   [2006]   [Aug]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC][PATCH 4/4] Rename lock_cpu_hotplug/unlock_cpu_hotplug

* Nick Piggin <> wrote:

> It really is just like a reentrant rw semaphore... I don't see the
> point of the name change, but I guess we don't like reentrant locks so
> calling it something else might go down better with Linus ;)

what would fit best is a per-cpu scalable (on the read-side)
self-reentrant rw mutex. We are doing cpu hotplug locking in things like
fork or the slab code, while most boxes will do a CPU hotplug event only
once in the kernel's lifetime (during bootup), so a classic global
read-write lock is unjustified.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2006-08-24 17:11    [from the cache]
©2003-2014 Jasper Spaans. hosted at Digital Ocean