[lkml]   [2006]   [Jul]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH -mm 0/7] execns syscall and user namespace
Cedric Le Goater wrote:
> H. Peter Anvin wrote:
>> I would like give a strong objection to the naming. The -ve() suffix in
>> execve() isn't jettisonable; it indicates its position within a family
>> of functions (only one of which is a true system call.)
>> execven() would be better name (the -n argument coming after then -e
>> argument). The library could then provide execlen(), execlpn() etc as
>> appropriate.
> I agree. execns() is a shortcut.
> This service behaves like execve() if the flag argument is 0, so I guess we
> should keep the execve- prefix. However, we could be a bit more explicit on
> the nature of this service and call it execve_unshare().

How about execveu()? -n looked a bit weird to me, mostly because the
"le" form would be execlen() which looks like something completely

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2006-07-11 21:31    [W:0.079 / U:2.248 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site