[lkml]   [2006]   [Jun]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 2.6.17-rc5 7/8] Remove some of the kmemleak false positives

> >>From: Catalin Marinas <>
> >>+ memleak_debug_not_leak(res);
> >
> > I'd suggest some shorter/more generic name.
> >
> > not_freed(res); ?
> >
> > alloc_forever(res); ?
> It's true that the names are a bit long ("debug" is even superfluous). I
> would, however, keep the memleak_ prefix as I think it makes the code
> clearer (i.e. the function belongs to a certain part of the kernel).

Well, in future some other leak detector may want to use these hooks.

Anyway memleak_not_leak() is already quite good.

(cesky, pictures)
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2006-06-03 23:34    [W:0.040 / U:0.980 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site