lkml.org 
[lkml]   [2006]   [Jun]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.6.16.19 + gcc-4.1.1
On Tue, Jun 13, 2006 at 19:23:30 -0700, Russell Whitaker wrote:
> hi
>
> First, I did this:
> made kernel with cpu=486, gcc-3.3.6
> worked fine.
>
> Next, changed cpu to k6, all else same.
> worked fine.
>
> Then, after mrproper, rebuilt with gcc-4.1.1, no other changes.
> compiles ok, installs ok. But, when attempting to load a module, get
> the following message: version magic '2.6.16.19via K6 gcc-4.1',
> should be '2.6.16.19via 486 gcc-3.3'

Did you reboot with the kernel built with gcc 4.1.1? The gcc version in
/proc/version has to match the gcc version of the module you want to
load..

Regards,
Tino
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-06-14 07:26    [W:0.045 / U:29.404 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site