[lkml]   [2006]   [Jun]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 1/1] usb: new driver for Cypress CY7C63xxx mirco controllers
On Út 13-06-06 23:30:24, Oliver Bock wrote:
> Hi Pavel,
> > > Hm, the chipset family is just called like that and there're at least
> > > three other Cypress related drivers (cypress, cypress_m8 and cytherm)
> > > with generic names. I think this name shows clearly what kind of device
> > > it supports, doesn't it?
> >
> > cypress_63 might be unique and still easier to pronounce?
> Hm, what about something related to the vendor "AK Modul-Bus Computer GmbH"?
> I think my driver might (!) only work for their firmware implementations...
> cypress_akmb
> cypress_akmodbus
> cypress_akmodulbus
> The third would be my favourite. Are there any length restrictions for
> driver/files names? Is it a problem to use parts of company names
> for this

No length limit; cypress_akmodulbus is quite long, but probably okay.

> > (You have it at few more places).
> I changed it. I had the rule "only tabs for indentation" on my mind and tried
> to choose the closest ;-) Now I first use tabs followed by spaces for
> fine-tuning (if needed).
> What about the macro discussion?
> If there's any convention I'm happy to follow it...

I'd prefer to do it using functions... it should be feasible. Only
repeated code will be function calls with different arguments.

(cesky, pictures)
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2006-06-14 00:21    [W:0.062 / U:1.568 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site