lkml.org 
[lkml]   [2006]   [Jun]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH 1/1] usb: new driver for Cypress CY7C63xxx mirco controllers
Date
Hi Pavel,

> > Hm, the chipset family is just called like that and there're at least
> > three other Cypress related drivers (cypress, cypress_m8 and cytherm)
> > with generic names. I think this name shows clearly what kind of device
> > it supports, doesn't it?
>
> cypress_63 might be unique and still easier to pronounce?

Hm, what about something related to the vendor "AK Modul-Bus Computer GmbH"?
I think my driver might (!) only work for their firmware implementations...

cypress_akmb
cypress_akmodbus
cypress_akmodulbus

The third would be my favourite. Are there any length restrictions for
driver/files names? Is it a problem to use parts of company names for this
purpose (I saw lego, rio, auerswald, etc.) or does one need to ask them for
permission in this case?

> > You mean the whole string (line) one character to the right, correct?
>
> Yes. It should be
>
> foo(BAR,
> BAZ).
>
> (You have it at few more places).

I changed it. I had the rule "only tabs for indentation" on my mind and tried
to choose the closest ;-) Now I first use tabs followed by spaces for
fine-tuning (if needed).

What about the macro discussion?
If there's any convention I'm happy to follow it...


Thanks,
Oliver

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-06-13 23:33    [W:0.072 / U:0.528 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site