lkml.org 
[lkml]   [2006]   [May]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    Subjectcannot load *any* modules with 2.4 kernel
    Hi,

    I boot two kernels, a 2.6.9 kernel and just recently built a 2.4.32 kernel

    In the 2.4.32 kernel I have =y for:
    CONFIG_MODULES
    CONFIG_MODVERSIONS
    CONFIG_KMOD

    I then build my kernel, with some modules, install the modules, and boot
    my 2.4.32 kernel successfully

    when i do lsmod, it is completely empty, no modules are loaded. This
    only happens for my 2.4.32 kernel though, modules load fine in 2.6.9

    If i try to manually insert with insmod or modprobe, i get unresolved
    external symbols for things that I am sure should be resolved... for
    example, i get unresolved external symbol for printk

    I'll give some other common unresolved smybols and maybe someone can
    point me in the right direction of what else i need to specify to you
    guys so that you can help me out further.

    prinkt
    add_timer
    dev_mc_add
    CardServices
    kfree
    cpu_raise_softirq
    free_irq
    kmalloc

    Thanks!
    George
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2006-05-20 18:11    [W:0.019 / U:34.464 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site