lkml.org 
[lkml]   [2006]   [May]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRE: ASUS A8V Deluxe, x86_64
Date
From
> >> sd 0:0:0:0: Attached scsi disk sda
> >> Vendor: PLEXTOR Model: DVDR PX-716A Rev: 1.09
> >> Type: CD-ROM ANSI SCSI revision: 05
> >
> > Above and the detailed log too indicate that everything went smooth
> > the first time around. Albert, do you have any ideas? Could it be
> > something related to irq-pio?

You cannot image how happy I was :)


> I've checked Vincent't dmesg for 2.6.17-rc0 again.
> (http://bugzilla.kernel.org/show_bug.cgi?id=5533)
> (http://bugzilla.kernel.org/attachment.cgi?id=7700&action=view)
>
> It seems DMA commands are also affected by this problem, not
> PIO unique.

> After comparing the code of 2.6.17-rc4 and current libata
> upstream, maybe "flush" is the fix:
> The CDB was sent to the ATAPI device by PIO, but not flushed
> to device.
> So, the device was busy waiting for the CDB to arrive.

> Hi Vincent,
> Could you please try 2.6.17-rc4, both with and without the
> attached patch, to see if the flush works. Thanks.

On a pure 2.6.17-rc4 without upstream libata patches I presume? Sure I will tonight.
I'll forward this patch to my home email address and come back to you.

- vin
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-05-18 12:59    [W:0.021 / U:19.276 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site