lkml.org 
[lkml]   [2006]   [May]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectHow to enable bios-disabled soundcard?
Context: IBM X20 laptop with integrated PCI CS4281 soundcard. Loading 
snd_cs4281 gives these messages and registers no alsa device:

ACPI: PCI interrupt for device 0000:00:0b.0 disabled
CS4281: probe of 0000:00:0b.0 failed with error -5

Error -5 seems to be -EIO.

There is no option ib bios to enable/disable the soundcard and the bios
is almost the latest (2.23, latest 2.25 fixes only unrelated things by
changelog).

lspci identifies the card as follows (pci ID is the same as in the
driver):
0000:00:0b.0 Multimedia audio controller: Cirrus Logic Crystal CS4281 PCI Audio (rev 01)

I tried pci=routeirq. It distributed the interrupts differently but this
problem did remain.

I tried acpi=ogg and the ACPI line disappeared but probe failure stayed.

So how can I enable the soundcard?

--
Meelis Roos (mroos@linux.ee)
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-05-18 16:12    [W:0.031 / U:2.548 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site