lkml.org 
[lkml]   [2006]   [May]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectBug related to bonding
Hi!

I am at a total loss with this one. My vanilla 2.4.32 crashes when I
try to use bonding together with my rtl8150 based (USB-Ethernet) NICs.
If this is a known error, I apologize for bothering the list and would
appreciate any pointers to a working solution/workaround.

Reproduce:
# modprobe bonding mode=1 miimon=100 maxbonds=4
# ifconfig bond0 172.16.10.111 netmask 255.255.255.0 up
# ifenslave bond0 eth1 eth2
Ethernet Channel Bonding Driver: v2.6.0 (January 14, 2004)
bonding: MII link monitoring set to 100 ms
00:60:6E:30:07:Scheduling in interrupt
kernel BUG at sched.c:564!
invalid operand: 0000
CPU: 0
EIP: 0010:[<c011461d>] Not tainted
EFLAGS: 00010282
...(following the CPU registers and Call Trace)....

Please let me know which details I have to provide from the bug message
(I have to type it in manually, no copy'n'paste possible:-)).

It is not clear to me whether this is a bug in the bonding module, in
the network driver or in the kernel itself.
All 2.6.x kernels I tried worked fine, but I am currently bound to a
2.4.x kernel and all 2.4.x kernels I tried (2.4.20, 2.4.29) showed
similiar problems when activating bonding.

Thank you in advance,
kind regards,
Heiko

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-05-15 11:38    [W:0.085 / U:1.440 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site